Jump to content

How can I only allow one computer on a jack?


wildweaselmi
 Share

Recommended Posts

If you have Cisco switches and running IOS (not CATOS) then you can run a command called sticky which means when a computer plugs into a jack that mac address sticks to the Cisco IOS security as the allowed mac-address.





This example shows how to enable sticky port security on a port, to manually configure MAC addresses for data VLAN and voice VLAN, and to set the total maximum number of secure addresses to 10 (5 for data VLAN and 5 for voice VLAN).



Switch(config)# interface FastEthernet0/1


Switch(config-if)# switchport access vlan 21


Switch(config-if)# switchport mode access


Switch(config-if)# switchport voice vlan 22


Switch(config-if)# switchport port-security


Switch(config-if)# switchport port-security maximum 10


Switch(config-if)# switchport port-security violation restrict


Switch(config-if)# switchport port-security mac-address sticky


Switch(config-if)# switchport port-security mac-address sticky 0000.0000.0002


Switch(config-if)# switchport port-security mac-address 0000.0000.0003


Switch(config-if)# switchport port-security mac-address sticky 0000.0000.0001 vlan voice


Switch(config-if)# switchport port-security mac-address 0000.0000.0004 vlan voice


Switch(config-if)# switchport port-security maximum 5 vlan access


Switch(config-if)# switchport port-security maximum 5 vlan voice[/code]


Link to comment
Share on other sites

 Share

×
×
  • Create New...