Jump to content

Cisco 3750 Stack


rev.dennis
 Share

Recommended Posts

When stacking your 3750's, try and keep a full bandwidth configuration (think of a loop that you can travel from top to bottom and have a cable going back to the top)





Here is a photo of FULL BANDWIDTH



picture.php?albumid=37&pictureid=994&thu





Here is a photo of HALF BANDWIDTH (no redundancy)



picture.php?albumid=37&pictureid=995&thu





Are you going to have redundant power as well?



Link to comment
Share on other sites

No worries :cool:





If you utilize the FULL BANDWIDTH configuration for your stackwise cables (note: you'll probably need on long stackwise cable to reach from the bottom to the top) you will have connectivity redundancy in the event one of the switches in the stack fail.





Now, something else that is common to fail is power. Currently without power redundancy you'll have something like the following



picture.php?albumid=37&pictureid=993&thu





With a Cisco RPS 675 (which is old and Cisco no longer sells them)



picture.php?albumid=44&pictureid=996&thu





Or the newer Cisco RPS 2300 (which is the replacement to the 675)



picture.php?albumid=37&pictureid=891&thu





With an RPS (Redundant Power Supply) with one cable plugged into UPS and the other into WALL power as shown above, you will always have power (until the battery drains)





Check out the YouTube video/advertisement



http://www.youtube.com/watch?v=3ETTO-HI-JA



Link to comment
Share on other sites

Ohh, I see. I have the stackwise cables but don't have a long cable to connect the bottom to the top so I'll have to get one of those.





How expensive is the redundant power supply and does it come with the DC cables needed to connect the cisco switches together?



Link to comment
Share on other sites

Powering Considerations





Consider the following guidelines before you power on the switches in a stack:





•The sequence in which you initially power on the switches might affect the switch that becomes the stack master.





•If you want a particular switch to become the stack master, power on that switch first. This switch becomes the stack master and remains the stack master until a master re-election is required. After approximately 10 seconds, power on the remaining switches in the stack.





•If you have no preference as to which switch becomes the stack master, power on all the switches in the stack within a 10-second timeframe. These switches participate in the stack master election. Switches powered up after the 10-second timeframe do not participate in the election.





•Power off a switch before you add it to or remove it from an existing switch stack.





As far as RPS price, a google search shows between $600 - $700 and not sure if the DC power cables come with it or not. I know seperatly they run about $150/each



Link to comment
Share on other sites

Basic Initial Configuration





Cisco IOS Software, C3750 Software (C3750-IPSERVICES-M), Version 12.2(25)SEB2, RELEASE SOFTWARE (fc1)


Copyright © 1986-2005 by Cisco Systems, Inc. Compiled Wed 08-Jun-05 01:19 by yenanh


Cisco IOS Software, C3750 Software (C3750-ADVIPSERVICESK9-M), Version 12.2(25)SEC2, RELEASE SOFTWARE (fc1)


Copyright © 1986-2005 by Cisco Systems, Inc.



Would you like to terminate autoinstall? : no



System Configuration Dialog



Would you like to enter the initial configuration dialog? : yes



At any point you may enter a question mark '?' for help.


Use ctrl-c to abort configuration dialog at any prompt.


Default settings are in square brackets '[]'.



Basic management setup configures only enough connectivity


for management of the system, extended setup will ask you


to configure each interface on the system



Would you like to enter basic management setup? : yes



Configuring global parameters:



Enter host name : CAT-3750 *** Note - use Your Standard Naming convention ***



The enable secret is a password used to protect access to


privileged EXEC and configuration modes. This password, after


entered, becomes encrypted in the configuration.



Enter enable secret: switch



The enable password is used when you do not specify an


enable secret password, with some older software versions, and


some boot images.



Enter enable password: packet



The virtual terminal password is used to protect


access to the router over a network interface.



Enter virtual terminal password: terminal



Configure SNMP Network Management? :no



Current interface summary



Any interface listed with OK? value "NO" does not have a valid configuration



Interface IP-Address OK? Method Status Protocol


Vlan1 unassigned NO unset up down


FastEthernet1/0/1-48 unassigned YES unset down down


GigabitEthernet1/0/1-4 unassigned YES unset down down



Enter interface name used to connect to the


management network from the above interface summary: vlan1



Configuring interface Vlan1:



Configure IP on this interface? : no



Would you like to enable as a cluster command switch? : no



Go to the IOS command prompt without saving this config.


Return back to the setup without saving this config.


Save this configuration to nvram and exit.



Enter your selection : 2


Building configuration...





Use the enabled mode 'configure' command to modify this configuration.



CAT-3750>




--------------------------------------------------------------------------------



Basic Switch Configuration



*****************************************************


***Reorder the switch stack


***Switches should be numbered from 1 – x


***Starting from the top


*****************************************************



CAT-3750#conf t


Enter configuration commands, one per line. End with CNTL/Z.



CAT-3750#switch current-stack-member-number renumber new-stack-member-number


***Note – Move switches to unused numbers first then back to correct numbers



CAT-3750#end



CAT-3750#reload





*****************************************************


***Set Priority of Switch Master


*****************************************************


CAT-3750#conf t


Enter configuration commands, one per line. End with CNTL/Z.



CAT-3750# switch stack-member-number priority new-priority-number


***Note – Top switch should be priority 15, each switch down 1 less



CAT-3750#end



*****************************************************


***Base Configuration



CAT-3750#ip routing



CAT-3750#conf t


Enter configuration commands, one per line. End with CNTL/Z.



CAT-3750(config)#interface vlan 101



CAT-3750(config-if)#no sh



CAT-3750(config-if)#ip address x.x.x.x x.x.x.x


*** Note – enter the IP address and subnetmask ***



CAT-3750(config-if)#name data_VLAN_101



CAT-3750(config-if)#exit



CAT-3750(config)#ip default-gateway x.x.x.x


*** Note – enter the IP address and subnet mask ***



CAT-3750(config)#no service pad



CAT-3750(config)#service timestamps debug uptime



CAT-3750(config)#service timestamps log uptime



CAT-3750(config)#no service password-encryption



CAT-3750(config)#vlan internal allocation policy ascending



CAT-3750(config)#ip classless



CAT-3750(config)#ip http server



CAT-3750(config)#snmp-server community public RO



CAT-3750(config)#snmp-server location sitename


*** Note - describe the location ***



CAT-3750(config)#ntp server x.x.x.x key 0


*** Note - replace with your ntp server



CAT-3750(config)#ntp server x.x.x.x key 0


*** Note - replace with your ntp server



CAT-3750(config)#ip domain-name something.com



*** Note - replace something with something




CAT-3750(config)#ip name-server x.x.x.x



*** Note - replace with a DNS Server



CAT-3750(config)#ip name-server x.x.x.x



*** Note - replace with a DNS Server



CAT-3750(config)#no file verify auto



CAT-3750(config)#spanning-tree mode pvst



CAT-3750(config)#spanning-tree extend system-id




CAT-3750(config)#end



CAT-3750#copy run start



Destination filename ?


Building configuration...






*****************************************************


***Configure Ports for Access


*****************************************************




CAT-3750#conf t


Enter configuration commands, one per line. End with CNTL/Z.



CAT-3750(config)#int range gig 1/0/1-4 , fa 1/0/1-48


***Note –enter the range of all ports, except router and etherchannel



CAT-3750(config-if-range)#Switchport Host (this command will configure the basic configuration of the port)


CAT-3750(config-if-range)# switchport access vlan 101



CAT-3750(config-if-range)#exit



CAT-3750(config)#int vlan1



CAT-3750(config-if)#shutdown



CAT-3750(config-if)#end



00:31:06: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively downt



CAT-3750#copy run start



Destination filename ?


Building configuration...










Ether Channel Switch Configuration



CAT-3750#conf t



CAT-3750(config)#interface Port-channel 1



CAT-3750(config-if)# switchport access vlan 101


CAT-3750(config-if)# switchport trunk native vlan 101


CAT-3750(config-if)# switchport mode dynamic desirable



CAT-3750(config-if)#exit



CAT-3750(config)#int range gigabitEthernet 1/0/1-4



*** Note – Range of ports to use in Channel



CAT-3750(config-if)# switchport access vlan 101


CAT-3750(config-if)# switchport trunk native vlan 101


CAT-3750(config-if)# switchport mode dynamic desirable



CAT-3750(config-if)# channel-group 1 mode desirable



CAT-3750(config-if)# spanning-tree portfast disable




CAT-3750(config-if)#end



CAT-3750#copy run start



Destination filename ?


Building configuration...




Link to comment
Share on other sites

 Share

×
×
  • Create New...