Jump to content

Provide DHCP from your Cisco L3 Switch


wildweaselmi
 Share

Recommended Posts

Here are the commands that worked for me






!

clock timezone EST -5

clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00

ip subnet-zero

ip domain-name MyWiseGuys.com

ip name-server 20.14.19.5

ip name-server 20.14.19.7

ip name-server 66.7.2.4

ip dhcp excluded-address 192.168.1.0 192.168.1.99

ip dhcp excluded-address 192.168.2.0 192.168.2.99

ip dhcp excluded-address 192.168.3.0 192.168.3.99

ip dhcp ping packets 5

!

ip dhcp pool 192.168.1.10

import all

network 192.168.1.0 255.255.255.0

domain-name home.com

default-router 192.168.1.1

dns-server 20.14.19.5 20.14.19.7 66.7.2.4

lease 0 8

!

ip dhcp pool 192.168.2.10

import all

network 192.168.2.0 255.255.255.0

domain-name business.com

default-router 192.168.2.1

dns-server 20.14.19.5 20.14.19.7 66.7.2.4

lease 0 8

!

ip dhcp pool 192.168.3.10

import all

network 192.168.3.0 255.255.255.0

domain-name T1.com

default-router 192.168.3.1

dns-server 20.14.19.5 20.14.19.7 66.7.2.4

lease 0 8


!

interface GigabitEthernet2/2

description home Internet

switchport access vlan 901

spanning-tree portfast

!

interface GigabitEthernet2/3

description business Internet

switchport access vlan 902

spanning-tree portfast

!

interface GigabitEthernet2/4

description T1 Internet

switchport access vlan 903

spanning-tree portfast

!


interface Vlan1

no ip address

!

interface Vlan900

ip address 172.31.7.1 255.255.255.0

!

interface Vlan901

ip address 192.168.1.2 255.255.255.0

ip helper-address 192.168.1.10

!

interface Vlan902

ip address 192.168.2.2 255.255.255.0

ip helper-address 192.168.2.10

!

interface Vlan903

ip address 192.168.3.2 255.255.255.0

ip helper-address 192.168.3.10

!

ip default-gateway 172.31.7.2

no ip http server

!

[/code]

Link to comment
Share on other sites

  • 2 weeks later...

ip name-server 206.141.193.55



ip name-server 206.141.195.76



ip name-server 66.73.20.40



ip dhcp excluded-address 192.168.1.0 192.168.1.99



ip dhcp excluded-address 192.168.2.0 192.168.2.99



ip dhcp excluded-address 192.168.3.0 192.168.3.99



ip dhcp ping packets 5



!



ip dhcp pool 192.168.1.10



import all



network 192.168.1.0 255.255.255.0



domain-name DSLhome.com



default-router 192.168.1.1



dns-server 206.141.193.55 206.141.195.76 66.73.20.40



lease 0 8



!



ip dhcp pool 192.168.2.10



import all



network 192.168.2.0 255.255.255.0



domain-name DSLbusiness.com



default-router 192.168.2.1



dns-server 206.141.193.55 206.141.195.76 66.73.20.40



lease 0 8



!



ip dhcp pool 192.168.3.10



import all



network 192.168.3.0 255.255.255.0



domain-name T1.com



default-router 192.168.3.1



dns-server 206.141.193.55 206.141.195.76 66.73.20.40



lease 0 8



!



interface Vlan465



ip address 192.168.1.2 255.255.255.0



ip helper-address 192.168.1.10



!



interface Vlan467



ip address 192.168.2.2 255.255.255.0



ip helper-address 192.168.2.10



!



interface Vlan468



ip address 192.168.3.2 255.255.255.0



ip helper-address 192.168.3.10



!



Link to comment
Share on other sites

 Share

×
×
  • Create New...