Jump to content

Dolby vision on Apple TV 4K blacking out


Cowboy Denny
 Share

Recommended Posts

What a pain in the butt this has been.  Watching the voice (my wife, not me) on YouTube TV and the screen goes black and comes back with Dolby Vision in the upper right corner.

Setup

 

Apple TV 4K

appleTV4k.jpg

 

Marantz 8K UHD AVR SR5015 - 7.2 Ch (2020 Model)

mz_sr50515_8kHDMIport.jpg

Sony OLED Bravia 55"

Some suggestions is to turn off Match Content, turn off dolby atmos if you aren’t using it.

 

If your TV is HDR…

Match Dynamic Range to On

After doing this, your apple tv transmits the content in the format because it is master so the hdr content is sent in HDR and transmits SDR content into SDR.

First, Power On your Apple Tv 

Using remote, Find- Open SettingsApp

Scroll the screen Video and Audio

click Match Content

Choose Match Dynamic Range and click to turn it ON/OFF

Match Frame Rate to On

(most movies are 24 frames per second)

Consequence of using the above settings, TVs rarely switch frame rates instantly, resulting in a momentary blank or no signal screen which is what we are seeing.

You can set Match Frame Rate to Off but doing so will remove the delay, but it will come at the risk of motion approximation distortions but just may fix the screen from blanking out 

 

Firmware

update firmware on TV, Receiver, Apple TV

Link to comment
Share on other sites

so far what appears to be working is making this simple change

1. make sure you have 8k HDMI cables for everything

2. make sure firmware is updated on everything

3. Finally

First, Power On your Apple Tv 

Using remote, Find- Open SettingsApp

Scroll the screen Video and Audio

click Match Content

Choose Match Dynamic Range and click to turn it ON

Choose Match Frame Rate and click to turn OFF

Link to comment
Share on other sites

No matter what setting we did, we kept getting the black out screens so just connected directly the Apple TV to HDMI 1 (non ARC HDMI) on our Sony 55" OLED and left the Marantz Receiver in the ARC HDMI2 port on the Sony 55" OLED TV so we can still get the awesome sound to the receiver and our 5.1 speakers.

Since Apple TV is plugged directly into the TV we haven't had any issues even after changing the settings on the Apple TV back to original settings:

  • Match Dynamic Range and click to turn it ON
  • Match Frame Rate and click to turn ON
Link to comment
Share on other sites

Was running into some sound issues connecting Apple TV directly to the Sony TV

I went into the Marantz Receiver Settings

Clicked on Video

Clicked on 4k/8k Signal Format

Changed from Enhanced (Default) to 8K Enhanced

   

Stan­dard:

Se­lect if your TV and play­back de­vices sup­port 4K 60p 4:2:0 8 bit video sig­nals.

En­hanced
(De­fault):

Se­lect if your TV, play­back de­vices, and ca­bles sup­port high qual­ity 4K 60p 4:4:4 8 bit, 4:2:2 or 4:2:0 10 bit video sig­nals.

8K En­hanced:

Se­lect if your TV, play­back de­vices, and ca­bles sup­port high qual­ity 8K 60p or 4K 120p video sig­nals.

Bracket Open Relation between the “4K/8K Signal Format” setting and supported resolutions Bracket Close

Sup­port Res­o­lu­tion

Color Space

Pixel Depth

4K/8K Sig­nal For­mat

Stan­dard

En­hanced

8K En­hanced

4K 24p,
4K 30p,
4K 25p

RGB /
YCbCr 4:4:4

8 bit

check_mark

check_mark

check_mark

10,12 bit

check_mark

check_mark

YCbCr 4:2:2

12 bit

check_mark

check_mark

check_mark

4K 60p,
4K 50p

YCbCr 4:2:0

8 bit

check_mark

check_mark

check_mark

10,12 bit

check_mark

check_mark

RGB /
YCbCr 4:4:4

8 bit

check_mark

check_mark

10,12 bit

check_mark

YCbCr 4:2:2

12 bit

check_mark

check_mark

4K 120p,
4K 100p

YCbCr 4:2:0

8,10,12 bit

check_mark

RGB /
YCbCr 4:4:4

8,10 bit

check_mark

YCbCr 4:2:2

12 bit

check_mark

8K 24p,
8K 30p,
8K 25p

YCbCr 4:2:0

8,10,12 bit

check_mark

RGB /
YCbCr 4:4:4

8,10 bit

check_mark

YCbCr 4:2:2

12 bit

check_mark

8K 60p,
8K 50p

YCbCr 4:2:0

8, 10 bit

check_mark

 
  • When setting this to “Enhanced”, we recommend using a “Premium High Speed HDMI Cable” or “Premium High Speed HDMI Cable with Ethernet” that has an “HDMI Premium Certified Cable” label attached to the product package.
  • When setting this to “8K Enhanced”, we recommend using an “Ultra High Speed 48 Gbps HDMI cable”.
  • When this setting is “Enhanced” or “8K Enhanced”, configure the television or playback device settings to match this setting.
  • When this setting is “Enhanced” or “8K Enhanced”, video may not be output correctly depending on the connected playback device or HDMI cable. In this case, change this setting to “Standard”.
Link to comment
Share on other sites

  • 2 weeks later...

Looks like the key that worked for me was plugging AppleTV directly into the TV.

My Sony Bravia OLED TV has HDMI/ARC on HDMI 3 so I leave that connected to my Marantz Receiver and I had the AppleTV plugged into HDMI4 or HDMI1 and it wasn't working but moved it to HDMI2 and all is good.  My only issue is when the TV is running Dolby Vision when I change the volume the Heads up of how much volume no longer displays.  I'm assuming its because the stereo doesn't support displaying in Dolby Vision.  It's something I can live with..  after awhile.

Link to comment
Share on other sites

 Share



×
×
  • Create New...