Linux

Group Admins

Other Groups

Build CentOS 8 Notes

  • This topic has 0 replies, 1 voice, and was last updated 1 week ago by admin.
Viewing 0 reply threads
  • Author
    Posts
    • #133
      admin
      Keymaster

      I downloaded the CentOS 8 DVD (10GB as of today) and installed on my VMWare ESXi host.

      First think I did once I connected via SSH with root is:

      Add a shell script file under /etc/profile. This will ensure the settings apply to all logged-in users.

      vi /etc/profile

      Add your proxy settings at the top of the file like this

      # /etc/profile

      # System wide environment and startup programs, for login setup
      # Functions and aliases go in /etc/bashrc

      # It’s NOT a good idea to change this file unless you know what you
      # are doing. It’s much better to create a custom.sh shell script in
      # /etc/profile.d/ to make custom changes to your environment, as this
      # will prevent the need for merging in future updates.

      PROXY_URL=”http://10.47.196.156:80/”

      export http_proxy=”$PROXY_URL”
      export https_proxy=”$PROXY_URL”
      export ftp_proxy=”$PROXY_URL”
      export no_proxy=”127.0.0.1,localhost”

      # For curl
      export HTTP_PROXY=”$PROXY_URL”
      export HTTPS_PROXY=”$PROXY_URL”
      export FTP_PROXY=”$PROXY_URL”
      export NO_PROXY=”127.0.0.1,localhost”

      If authentication is required just replace

      PROXY_URL=”http://10.47.196.156:80/”

      with

      PROXY_URL=”http://username:password@10.47.196.156:80/”

      Source the file when done to start using the proxy settings, or alternatively logout and back in.

      source /etc/profile

      Confirm you are setup now to use the PROXY settings

      env | grep -i proxy

      Now let’s make sure dnf package manager can upgrade through the proxy

      vi /etc/dnf/dnf.conf

      Add

      proxy=http://proxyserver:port

      Hope this helps your CentOS 8 box get connected through a proxy

      0
      0
Viewing 0 reply threads
  • You must be logged in to reply to this topic.